Ubuntu 16.04 执行 apt-get install 时报错的解决办法


apt更新如果非正常结束,会留有lock文件、以及许多更新缓存文件,导致无法继续执行apt update操作。解决办法是手工删除这些文件,即可正常使用apt update更新命令。

报错如下:

parallels@ubuntu:~$ sudo apt-get install fcitx-config-gtk
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

起初我安装上面的提示执行,依旧报错

sudo dpkg --configure -a

解决方法:

# 删除/var/lib/dpkg/lock文件
sudo rm  /var/lib/dpkg/lock
# 清除apt缓存
sudo apt clean
# 删除/var/lib/dpkg/updates/下所有文件
sudo rm /var/lib/dpkg/updates/*
# 执行更新程序
sudo apt update

最后执行

parallels@ubuntu:~$ sudo apt-get install fcitx-config-gtk

问题解决

附件: