Mac上 Python安装Pillow问题


问题

安装 pip install Pillow==3.3.0 的时候出错

ValueError: zlib is required unless explicitly disabled using --disable-zlib, aborting

原因是pillow在3.0以上的版本需要有依赖库, libjpegzlib

解决方法 :

打开mac的终端, 安装brew

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

通过brew安装libjpeg

brew install libjpeg zlib

通过brew安装zlib

brew tap homebrew/dupes
brew install zlib
brew link zlib --force

之后再正常安装pillow即可

附件: